CVE-2023-38693

Critical

Description

Lucee Server (or simply Lucee) is a dynamic, Java based, tag and scripting language used for rapid web application development. The Lucee REST endpoint is vulnerable to RCE via an XML XXE attack. This vulnerability is fixed in Lucee 5.4.3.2, 5.3.12.1, 5.3.7.59, 5.3.8.236, and 5.3.9.173.

SeverityCritical
CVSS9.8
Exploit probability—
ProductOrg.lucee:lucee
PublishedMar 5, 2025
First seenMar 5, 2025

How to fix

Update
  • org.lucee:lucee5.3.12.1, 5.4.3.2, 5.3.8.236, 5.3.9.173 or later

Affected products

ProductAffected versionsFixed in
org.lucee:luceeMaven5.3.10.79-RC ≤ v < 5.3.12.1, 5.4.0.65-RC ≤ v < 5.4.3.2, v ≤ 5.3.7.59, 5.3.8.132-RC ≤ v < 5.3.8.236, 5.3.9.113 ≤ v < 5.3.9.1735.3.12.1, 5.4.3.2, 5.3.8.236, 5.3.9.173

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.