CVE-2023-39410
High
Description
When deserializing untrusted or corrupted data, it is possible for a reader to consume memory beyond the allowed constraints and thus lead to out of memory on the system. This issue affects Java applications using Apache Avro Java SDK up to and including 1.11.2. Users should update to apache-avro version 1.11.3 which addresses this issue.
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Avro
PublishedSep 29, 2023
First seenSep 29, 2023
Weakness typeCWE-502Deserialization of untrusted data
How to fix
Update
- apache avro1.11.3 or later
- avro1.11.3 or later
- org.apache.avro:avro1.11.3 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache avro | v < 1.11.3 | 1.11.3 |
| avroPyPI | v < 1.11.3 | 1.11.3 |
| org.apache.avro:avroMaven | v < 1.11.3 | 1.11.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.