CVE-2023-39441
Description
Apache Airflow SMTP Provider before 1.3.0, Apache Airflow IMAP Provider before 3.3.0, and Apache Airflow before 2.7.0 are affected by the Validation of OpenSSL Certificate vulnerability. The default SSL context with SSL library did not check a server's X.509 certificate. Instead, the code accepted any certificate, which could result in the disclosure of mail server credentials or mail contents when the client connects to an attacker in a MITM position. Users are strongly advised to upgrade to Apache Airflow version 2.7.0 or newer, Apache Airflow IMAP Provider version 3.3.0 or newer, and Apache Airflow SMTP Provider version 1.3.0 or newer to mitigate the risk associated with this vulnerability
How to fix
- apache airflow2.7.0 or later
- apache apache-airflow-providers-imap3.3.0 or later
- apache apache-airflow-providers-smtp1.3.0 or later
- apache-airflow-providers-smtp1.3.0 or later
- apache-airflow-providers-imap3.3.0 or later
- apache-airflow2.7.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache airflow | v < 2.7.0 | 2.7.0 |
| apache apache-airflow-providers-imap | v < 3.3.0 | 3.3.0 |
| apache apache-airflow-providers-smtp | v < 1.3.0 | 1.3.0 |
| apache-airflow-providers-smtpPyPI | v < 1.3.0 | 1.3.0 |
| apache-airflow-providers-imapPyPI | v < 3.3.0 | 3.3.0 |
| apache-airflowPyPI | v < 2.7.0 | 2.7.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.