CVE-2023-40023
Description
yaklang is a programming language designed for cybersecurity. The Yak Engine has been found to contain a local file inclusion (LFI) vulnerability. This vulnerability allows attackers to include files from the server's local file system through the web application. When exploited, this can lead to the unintended exposure of sensitive data, potential remote code execution, or other security breaches. Users utilizing versions of the Yak Engine prior to 1.2.4-sp1 are impacted. This vulnerability has been patched in version 1.2.4-sp1. Users are advised to upgrade. users unable to upgrade may avoid exposing vulnerable versions to untrusted input and to closely monitor any unexpected server behavior until they can upgrade.
How to fix
- github.com/yaklang/yaklang1.2.4-sp2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| yaklang yaklang | 1.2.0, 1.2.1, 1.2.2, 1.2.3, 1.2.4 | — |
| github.com/yaklang/yaklangGo | v < 1.2.4-sp2 | 1.2.4-sp2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.