CVE-2023-40032

Medium

Description

libvips is a demand-driven, horizontally threaded image processing library. A specially crafted SVG input can cause libvips versions 8.14.3 or earlier to segfault when attempting to parse a malformed UTF-8 character. Users should upgrade to libvips version 8.14.4 (or later) when processing untrusted input.

SeverityMedium
CVSS5.5
Exploit probability—
ProductLibvips
PublishedSep 11, 2023
First seenSep 11, 2023

How to fix

Update
  • libvips libvips8.14.4 or later

Affected products

ProductAffected versionsFixed in
libvips libvips8.12.0 ≤ v < 8.14.48.14.4
fedoraproject fedora39—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.