CVE-2023-40033

High

Description

Flarum is an open source forum software. Flarum is affected by a vulnerability that allows an attacker to conduct a Blind Server-Side Request Forgery (SSRF) attack or disclose any file on the server, even with a basic user account on any Flarum forum. By uploading a file containing a URL and spoofing the MIME type, an attacker can manipulate the application to execute unintended actions. The vulnerability is due to the behavior of the `intervention/image` package, which attempts to interpret the supplied file contents as a URL, which then fetches its contents. This allows an attacker to exploit the vulnerability to perform SSRF attacks, disclose local file contents, or conduct a blind oracle attack. This has been patched in Flarum version 1.8.0. Users are advised to upgrade. Users unable to upgrade may disable PHP's `allow_url_fopen` which will prevent the fetching of external files via URLs as a temporary workaround for the SSRF aspect of the vulnerability.

SeverityHigh
CVSS7.1
Exploit probability—
ProductFlarum
PublishedAug 16, 2023
First seenAug 16, 2023

How to fix

Update
  • flarum flarum1.8.0 or later
  • flarum/core1.8.0 or later
  • flarum/framework1.8.0 or later

Affected products

ProductAffected versionsFixed in
flarum flarumv < 1.8.01.8.0
flarum/corePackagistv < 1.8.01.8.0
flarum/frameworkPackagistv < 1.8.01.8.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.