CVE-2023-40035
Description
Craft is a CMS for creating custom digital experiences on the web and beyond. Bypassing the validatePath function can lead to potential remote code execution. This vulnerability can lead to malicious control of vulnerable systems and data exfiltrations. Although the vulnerability is exploitable only in the authenticated users, configuration with ALLOW_ADMIN_CHANGES=true, there is still a potential security threat (Remote Code Execution). This issue has been patched in version 4.4.15 and version 3.8.15.
How to fix
- craftcms craft_cms3.8.15, 4.4.15 or later
- craftcms/cms4.4.15, 3.8.15 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| craftcms craft_cms | 3.0.0 ≤ v < 3.8.15, 4.0.0 ≤ v < 4.4.15, 4.0.0 | 3.8.15, 4.4.15 |
| craftcms/cmsPackagist | 4.0.0-RC1 ≤ v < 4.4.15, 3.0.0 ≤ v < 3.8.15 | 4.4.15, 3.8.15 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.