CVE-2023-40311
Description
Multiple stored XSS were found on different JSP files with unsanitized parameters in OpenMNS Horizon 31.0.8 and versions earlier than 32.0.2 on multiple platforms that allow an attacker to store on database and then load on JSPs or Angular templates. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet. OpenNMS thanks Jordi Miralles Comins for reporting this issue.
How to fix
- opennms horizon32.0.2 or later
- opennms meridian2020.1.38, 2022.1.19, 2023.1.6 or later
- org.opennms:opennms-webapp32.0.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| opennms horizon | 31.0.8 ≤ v < 32.0.2 | 32.0.2 |
| opennms meridian | v < 2020.1.38, 2022.1.0 ≤ v < 2022.1.19, 2023.1.0 ≤ v < 2023.1.6 | 2020.1.38, 2022.1.19, 2023.1.6 |
| org.opennms:opennms-webappMaven | 31.0.8 ≤ v < 32.0.2 | 32.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.