CVE-2023-40313

High

Description

A BeanShell interpreter in remote server mode runs in OpenMNS Horizon versions earlier than 32.0.2 and in related Meridian versions which could allow arbitrary remote Java code execution. The solution is to upgrade to Meridian 2023.1.6, 2022.1.19, 2021.1.30, 2020.1.38 or Horizon 32.0.2 or newer. Meridian and Horizon installation instructions state that they are intended for installation within an organization's private networks and should not be directly accessible from the Internet.

SeverityHigh
CVSS7.1
Exploit probability—
ProductOpennms Horizon
PublishedAug 17, 2023
First seenAug 17, 2023

How to fix

Update
  • opennms horizon32.0.2 or later
  • opennms meridian2020.1.38, 2021.1.30, 2022.1.19, 2023.1.6 or later
  • org.opennms:opennms-base-assembly32.0.2 or later

Affected products

ProductAffected versionsFixed in
opennms horizonv < 32.0.232.0.2
opennms meridianv < 2020.1.38, 2021.1.0 ≤ v < 2021.1.30, 2022.1.0 ≤ v < 2022.1.19, 2023.1.0 ≤ v < 2023.1.62020.1.38, 2021.1.30, 2022.1.19, 2023.1.6
org.opennms:opennms-base-assemblyMavenv < 32.0.232.0.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.