CVE-2023-41267

High

Description

In the Apache Airflow HDFS Provider, versions prior to 4.1.1, a documentation info pointed users to an install incorrect pip package. As this package name was unclaimed, in theory, an attacker could claim this package and provide code that would be executed when this package was installed. The Airflow team has since taken ownership of the package (neutralizing the risk), and fixed the doc strings in version 4.1.1

SeverityHigh
CVSS7.8
Exploit probability—
ProductApache Airflow Hdfs Provider
PublishedSep 14, 2023
First seenSep 14, 2023
Weakness typeCWE-829CWE-829

How to fix

Update
  • apache airflow_hdfs_provider4.1.1 or later
  • apache-airflow-providers-apache-hdfs4.1.1 or later

Affected products

ProductAffected versionsFixed in
apache airflow_hdfs_providerv < 4.1.14.1.1
apache-airflow-providers-apache-hdfsPyPIv < 4.1.14.1.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.