CVE-2023-41890

High

Description

Sustainsys.Saml2 library adds SAML2P support to ASP.NET web sites, allowing the web site to act as a SAML2 Service Provider. Prior to versions 1.0.3 and 2.9.2, when a response is processed, the issuer of the Identity Provider is not sufficiently validated. This could allow a malicious identity provider to craft a Saml2 response that is processed as if issued by another identity provider. It is also possible for a malicious end user to cause stored state intended for one identity provider to be used when processing the response from another provider. An application is impacted if they rely on any of these features in their authentication/authorization logic: the issuer of the generated identity and claims; or items in the stored request state (AuthenticationProperties). This issue is patched in versions 2.9.2 and 1.0.3. The `AcsCommandResultCreated` notification can be used to add the validation required if an upgrade to patched packages is not possible.

SeverityHigh
CVSS7.5
Exploit probability—
ProductSustainsys Saml2
PublishedSep 19, 2023
First seenSep 19, 2023

How to fix

Update
  • sustainsys saml21.0.3, 2.9.2 or later
  • Sustainsys.Saml21.0.3, 2.9.2 or later

Affected products

ProductAffected versionsFixed in
sustainsys saml2v < 1.0.3, 2.0.0 ≤ v < 2.9.21.0.3, 2.9.2
Sustainsys.Saml2NuGetv < 1.0.3, 2.0.0 ≤ v < 2.9.21.0.3, 2.9.2
Kentor.AuthServicesNuGetv ≤ 0.23.0—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-41890 · Sustainsys Saml2 · Dark Radar