CVE-2023-42460

Medium

Description

Vyper is a Pythonic Smart Contract Language for the EVM. The `_abi_decode()` function does not validate input when it is nested in an expression. Uses of `_abi_decode()` can be constructed which allow for bounds checking to be bypassed resulting in incorrect results. This issue has not yet been fixed, but a fix is expected in release `0.3.10`. Users are advised to reference pull request #3626.

SeverityMedium
CVSS5.3
Exploit probability—
ProductVyper
PublishedSep 27, 2023
First seenSep 27, 2023
Weakness typeCWE-682CWE-682

How to fix

Update
  • vyperlang vyper0.3.10 or later
  • vyper0.3.10 or later

Affected products

ProductAffected versionsFixed in
vyperlang vyper0.3.4 ≤ v < 0.3.100.3.10
vyperPyPI0.3.4 ≤ v < 0.3.100.3.10

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.