CVE-2023-42501
Medium
Description
Unnecessary read permissions within the Gamma role would allow authenticated users to read configured CSS templates and annotations. This issue affects Apache Superset: before 2.1.2. Users should upgrade to version or above 2.1.2 and run `superset init` to reconstruct the Gamma role or remove `can_read` permission from the mentioned resources.
SeverityMedium
CVSS4.3
Exploit probability—
Product
Apache Superset
PublishedNov 27, 2023
First seenNov 27, 2023
Weakness typeCWE-276CWE-276
How to fix
Update
- apache superset2.1.1 or later
- apache-superset2.1.2 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache superset | v < 2.1.1 | 2.1.1 |
| apache-supersetPyPI | v < 2.1.2 | 2.1.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.