CVE-2023-42780

Medium

Description

Apache Airflow, versions prior to 2.7.2, contains a security vulnerability that allows authenticated users of Airflow to list warnings for all DAGs, even if the user had no permission to see those DAGs. It would reveal the dag_ids and the stack-traces of import errors for those DAGs with import errors. Users of Apache Airflow are advised to upgrade to version 2.7.2 or newer to mitigate the risk associated with this vulnerability.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Airflow
PublishedOct 14, 2023
First seenOct 14, 2023

How to fix

Update
  • apache airflow2.7.2 or later
  • apache-airflow2.7.2 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 2.7.22.7.2
apache-airflowPyPIv < 2.7.22.7.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.