CVE-2023-42781

Medium

Description

Apache Airflow, versions before 2.7.3, has a vulnerability that allows an authorized user who has access to read specific DAGs only, to read information about task instances in other DAGs.  This is a different issue than CVE-2023-42663 but leading to similar outcome. Users of Apache Airflow are advised to upgrade to version 2.7.3 or newer to mitigate the risk associated with this vulnerability.

SeverityMedium
CVSS6.5
Exploit probability—
ProductApache Airflow
PublishedNov 12, 2023
First seenNov 12, 2023

How to fix

Update
  • apache airflow2.7.3 or later
  • apache-airflow2.7.3 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 2.7.32.7.3
apache-airflowPyPIv < 2.7.32.7.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.