CVE-2023-42820
Description
JumpServer is an open source bastion host. This vulnerability is due to exposing the random number seed to the API, potentially allowing the randomly generated verification codes to be replayed, which could lead to password resets. If MFA is enabled users are not affect. Users not using local authentication are also not affected. Users are advised to upgrade to either version 2.28.19 or to 3.6.5. There are no known workarounds or this issue.
How to fix
- fit2cloud jumpserver2.28.19, 3.6.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| fit2cloud jumpserver | 2.24.0 ≤ v < 2.28.19, 3.0.0 ≤ v < 3.6.5 | 2.28.19, 3.6.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.