CVE-2023-43643

Medium

Description

AntiSamy is a library for performing fast, configurable cleansing of HTML coming from untrusted sources. Prior to version 1.7.4, there is a potential for a mutation XSS (mXSS) vulnerability in AntiSamy caused by flawed parsing of the HTML being sanitized. To be subject to this vulnerability the `preserveComments` directive must be enabled in your policy file and also allow for certain tags at the same time. As a result, certain crafty inputs can result in elements in comment tags being interpreted as executable when using AntiSamy's sanitized output. This issue has been patched in AntiSamy 1.7.4 and later.

SeverityMedium
CVSS6.1
Exploit probability—
ProductAntisamy
PublishedOct 9, 2023
First seenOct 9, 2023

How to fix

Update
  • antisamy_project antisamy1.7.4 or later
  • org.owasp.antisamy:antisamy1.7.4 or later

Affected products

ProductAffected versionsFixed in
antisamy_project antisamyv < 1.7.41.7.4
org.owasp.antisamy:antisamyMavenv < 1.7.41.7.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.