CVE-2023-43645

Medium

Description

OpenFGA is an authorization/permission engine built for developers and inspired by Google Zanzibar. OpenFGA is vulnerable to a denial of service attack when certain Check calls are executed against authorization models that contain circular relationship definitions. When the call is made, it's possible for the server to exhaust resources and die. Users are advised to upgrade to v1.3.2 and update any offending models. There are no known workarounds for this vulnerability. Note that for models which contained cycles or a relation definition that has the relation itself in its evaluation path, checks and queries that require evaluation will no longer be evaluated on v1.3.2+ and will return errors instead. Users who do not have cyclic models are unaffected.

SeverityMedium
CVSS5.9
Exploit probability61. percentile0.9%
ProductOpenfga
PublishedSep 27, 2023
First seenSep 27, 2023
Weakness typeCWE-835CWE-835

How to fix

Update
  • openfga openfga1.3.2 or later
  • github.com/openfga/openfga1.3.2 or later

Affected products

ProductAffected versionsFixed in
openfga openfgav < 1.3.21.3.2
github.com/openfga/openfgaGov < 1.3.21.3.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-43645 · Openfga · Dark Radar