CVE-2023-43666
Medium
Description
Insufficient Verification of Data Authenticity vulnerability in Apache InLong.This issue affects Apache InLong: from 1.4.0 through 1.8.0, General user can view all user data like Admin account. Users are advised to upgrade to Apache InLong's 1.9.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/8623
SeverityMedium
CVSS6.5
Exploit probability—
Product
Apache Inlong
PublishedOct 16, 2023
First seenOct 16, 2023
Weakness typeCWE-345CWE-345
How to fix
Update
- org.apache.inlong:inlong1.9.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache inlong | 1.4.0 ≤ v ≤ 1.8.0 | — |
| org.apache.inlong:inlongMaven | 1.4.0 ≤ v < 1.9.0 | 1.9.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.