CVE-2023-43701

Medium

Description

Improper payload validation and an improper REST API response type, made it possible for an authenticated malicious actor to store malicious code into Chart's metadata, this code could get executed if a user specifically accesses a specific deprecated API endpoint. This issue affects Apache Superset versions prior to 2.1.2.  Users are recommended to upgrade to version 2.1.2, which fixes this issue.

SeverityMedium
CVSS4.3
Exploit probability—
ProductApache Superset
PublishedNov 27, 2023
First seenNov 27, 2023

How to fix

Update
  • apache superset2.1.2 or later
  • apache-superset2.1.2 or later

Affected products

ProductAffected versionsFixed in
apache supersetv < 2.1.22.1.2
apache-supersetPyPIv < 2.1.22.1.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.