CVE-2023-43826

High

Description

Apache Guacamole 1.5.3 and older do not consistently ensure that values received from a VNC server will not result in integer overflow. If a user connects to a malicious or compromised VNC server, specially-crafted data could result in memory corruption, possibly allowing arbitrary code to be executed with the privileges of the running guacd process. Users are recommended to upgrade to version 1.5.4, which fixes this issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Guacamole
PublishedDec 19, 2023
First seenDec 19, 2023

How to fix

Affected products

ProductAffected versionsFixed in
apache guacamolev ≤ 1.5.3—

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.