CVE-2023-44313

High

Description

Server-Side Request Forgery (SSRF) vulnerability in Apache ServiceComb Service-Center. Attackers can obtain sensitive server information through specially crafted requests.This issue affects Apache ServiceComb before 2.1.0(include). Users are recommended to upgrade to version 2.2.0, which fixes the issue.

SeverityHigh
CVSS7.6
Exploit probability—
ProductApache Servicecomb
PublishedJan 31, 2024
First seenJan 31, 2024

How to fix

Update
  • apache servicecomb2.2.0 or later
  • github.com/apache/servicecomb-service-center2.2.0 or later

Affected products

ProductAffected versionsFixed in
apache servicecombv < 2.2.02.2.0
github.com/apache/servicecomb-service-centerGov < 2.2.0, No range specified2.2.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.