CVE-2023-4504
High
Description
Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.
SeverityHigh
CVSS7.0
Exploit probability—
Product
Openprinting Cups
PublishedSep 21, 2023
First seenSep 21, 2023
Weakness typeCWE-122CWE-122
How to fix
Update
- openprinting cups2.4.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| openprinting cups | v < 2.4.7 | 2.4.7 |
| openprinting libppd | 2.0 | — |
| fedoraproject fedora | 37, 38, 39 | — |
| debian debian_linux | 10.0 | — |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.