CVE-2023-45144

Critical

Description

com.xwiki.identity-oauth:identity-oauth-ui is a package to aid in building identity and service providers based on OAuth authorizations. When a user logs in via the OAuth method, the identityOAuth parameters sent in the GET request is vulnerable to cross site scripting (XSS) and XWiki syntax injection. This allows remote code execution via the groovy macro and thus affects the confidentiality, integrity and availability of the whole XWiki installation. The issue has been fixed in Identity OAuth version 1.6. There are no known workarounds for this vulnerability and users are advised to upgrade.

SeverityCritical
CVSS10.0
Exploit probability—
ProductXwiki Oauth Identity
PublishedOct 16, 2023
First seenOct 16, 2023

How to fix

Update
  • xwiki oauth_identity1.6 or later
  • com.xwiki.identity-oauth:identity-oauth-ui1.6 or later

Affected products

ProductAffected versionsFixed in
xwiki oauth_identity1.0 ≤ v < 1.61.6
com.xwiki.identity-oauth:identity-oauth-uiMaven1.0 ≤ v < 1.61.6

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.