CVE-2023-45648
Description
Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M11, from 10.1.0-M1 through 10.1.13, from 9.0.0-M1 through 9.0.81 and from 8.5.0 through 8.5.93 did not correctly parse HTTP trailer headers. A specially crafted, invalid trailer header could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M12 onwards, 10.1.14 onwards, 9.0.81 onwards or 8.5.94 onwards, which fix the issue.
How to fix
- apache tomcat8.5.94, 9.0.81, 10.1.14 or later
- org.apache.tomcat:tomcat11.0.0-M12, 10.1.14, 9.0.81, 8.5.94 or later
- org.apache.tomcat.embed:tomcat-embed-core11.0.0-M12, 10.1.14, 9.0.81, 8.5.94 or later
- org.apache.tomcat:tomcat-coyote11.0.0-M12, 10.1.14, 9.0.81, 8.5.94 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | 8.5.0 ≤ v < 8.5.94, 9.0.1 ≤ v < 9.0.81, 10.1.1 ≤ v < 10.1.14, 9.0.0, 10.1.0, 11.0.0 | 8.5.94, 9.0.81, 10.1.14 |
| debian debian_linux | 10.0, 11.0, 12.0 | — |
| org.apache.tomcat:tomcatMaven | 11.0.0-M1 ≤ v < 11.0.0-M12, 10.1.0-M1 ≤ v < 10.1.14, 9.0.0-M1 ≤ v < 9.0.81, 8.5.0 ≤ v < 8.5.94 | 11.0.0-M12, 10.1.14, 9.0.81, 8.5.94 |
| org.apache.tomcat.embed:tomcat-embed-coreMaven | 11.0.0-M1 ≤ v < 11.0.0-M12, 10.1.0-M1 ≤ v < 10.1.14, 9.0.0-M1 ≤ v < 9.0.81, 8.5.0 ≤ v < 8.5.94 | 11.0.0-M12, 10.1.14, 9.0.81, 8.5.94 |
| org.apache.tomcat:tomcat-coyoteMaven | 11.0.0-M1 ≤ v < 11.0.0-M12, 10.1.0-M1 ≤ v < 10.1.14, 9.0.0-M1 ≤ v < 9.0.81, 8.5.0 ≤ v < 8.5.94 | 11.0.0-M12, 10.1.14, 9.0.81, 8.5.94 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.