CVE-2023-46118
Description
RabbitMQ is a multi-protocol messaging and streaming broker. HTTP API did not enforce an HTTP request body limit, making it vulnerable for denial of service (DoS) attacks with very large messages. An authenticated user with sufficient credentials can publish a very large messages over the HTTP API and cause target node to be terminated by an "out-of-memory killer"-like mechanism. This vulnerability has been patched in versions 3.11.24 and 3.12.7.
How to fix
- vmware rabbitmq3.11.24, 3.12.7 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| vmware rabbitmq | v < 3.11.24, 3.12.0 ≤ v < 3.12.7 | 3.11.24, 3.12.7 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.