CVE-2023-46131

Medium

Description

Grails is a framework used to build web applications with the Groovy programming language. A specially crafted web request can lead to a JVM crash or denial of service. Any Grails framework application using Grails data binding is vulnerable. This issue has been patched in version 3.3.17, 4.1.3, 5.3.4, 6.1.0.

SeverityMedium
CVSS6.5
Exploit probability—
ProductGrails
PublishedDec 21, 2023
First seenDec 21, 2023

How to fix

Update
  • grails grails3.3.17, 4.1.3, 5.3.4, 6.1.0 or later
  • org.grails:grails-databinding6.1.0, 5.3.4, 4.1.3, 3.3.17 or later

Affected products

ProductAffected versionsFixed in
grails grailsv < 3.3.17, 4.0.0 ≤ v < 4.1.3, 5.0.0 ≤ v < 5.3.4, 6.0.0 ≤ v < 6.1.03.3.17, 4.1.3, 5.3.4, 6.1.0
org.grails:grails-databindingMaven6.0.0 ≤ v < 6.1.0, 5.0.0 ≤ v < 5.3.4, 4.0.0 ≤ v < 4.1.3, 2.0.0 ≤ v < 3.3.176.1.0, 5.3.4, 4.1.3, 3.3.17

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-46131 · Grails · Dark Radar