CVE-2023-46226
Critical
Description
Remote Code Execution vulnerability in Apache IoTDB.This issue affects Apache IoTDB: from 1.0.0 through 1.2.2. Users are recommended to upgrade to version 1.3.0, which fixes the issue.
SeverityCritical
CVSS9.8
Exploit probability—
Product
Apache Iotdb
PublishedJan 15, 2024
First seenJan 15, 2024
Weakness typeCWE-94Code injection
How to fix
Update
- apache iotdb1.3.0 or later
- org.apache.iotdb:iotdb-core1.3.0 or later
- apache-iotdb1.3.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache iotdb | 1.0.0 ≤ v < 1.3.0 | 1.3.0 |
| org.apache.iotdb:iotdb-coreMaven | 1.0.0 ≤ v < 1.3.0 | 1.3.0 |
| apache-iotdbPyPI | 1.0.0 ≤ v < 1.3.0 | 1.3.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.