CVE-2023-46227
High
Description
Deserialization of Untrusted Data Vulnerability in Apache Software Foundation Apache InLong. This issue affects Apache InLong: from 1.4.0 through 1.8.0, the attacker can use \t to bypass. Users are advised to upgrade to Apache InLong's 1.9.0 or cherry-pick [1] to solve it. [1] https://github.com/apache/inlong/pull/8814
SeverityHigh
CVSS7.5
Exploit probability—
Product
Apache Inlong
PublishedOct 19, 2023
First seenOct 19, 2023
Weakness typeCWE-502Deserialization of untrusted data
How to fix
Update
- apache inlong1.9.0 or later
- org.apache.inlong:manager-common1.9.0 or later
- org.apache.inlong:manager-pojo1.9.0 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache inlong | 1.4.0 ≤ v < 1.9.0 | 1.9.0 |
| org.apache.inlong:manager-commonMaven | 1.4.0 ≤ v < 1.9.0 | 1.9.0 |
| org.apache.inlong:manager-pojoMaven | 1.4.0 ≤ v < 1.9.0 | 1.9.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.