CVE-2023-46246

Medium

Description

Vim is an improved version of the good old UNIX editor Vi. Heap-use-after-free in memory allocated in the function `ga_grow_inner` in in the file `src/alloc.c` at line 748, which is freed in the file `src/ex_docmd.c` in the function `do_cmdline` at line 1010 and then used again in `src/cmdhist.c` at line 759. When using the `:history` command, it's possible that the provided argument overflows the accepted value. Causing an Integer Overflow and potentially later an use-after-free. This vulnerability has been patched in version 9.0.2068.

SeverityMedium
CVSS4.0
Exploit probability—
ProductVim
PublishedOct 27, 2023
First seenOct 27, 2023

How to fix

Update
  • vim vim9.0.2068 or later

Affected products

ProductAffected versionsFixed in
vim vimv < 9.0.20689.0.2068

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.