CVE-2023-46288
Description
Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache Airflow.This issue affects Apache Airflow from 2.4.0 to 2.7.0. Sensitive configuration information has been exposed to authenticated users with the ability to read configuration via Airflow REST API for configuration even when the expose_config option is set to non-sensitive-only. The expose_config option is False by default. It is recommended to upgrade to a version that is not affected if you set expose_config to non-sensitive-only configuration. This is a different error than CVE-2023-45348 which allows authenticated user to retrieve individual configuration values in 2.7.* by specially crafting their request (solved in 2.7.2). Users are recommended to upgrade to version 2.7.2, which fixes the issue and additionally fixes CVE-2023-45348.
How to fix
- apache airflow2.7.0 or later
- apache-airflow2.7.2, 2.7.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache airflow | 2.4.0 ≤ v < 2.7.0 | 2.7.0 |
| apache-airflowPyPI | 2.4.0 ≤ v < 2.7.2, 2.4.0 ≤ v < 2.7.0 | 2.7.2, 2.7.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.