CVE-2023-46589
Description
Improper Input Validation vulnerability in Apache Tomcat.Tomcat from 11.0.0-M1 through 11.0.0-M10, from 10.1.0-M1 through 10.1.15, from 9.0.0-M1 through 9.0.82 and from 8.5.0 through 8.5.95 did not correctly parse HTTP trailer headers. A trailer header that exceeded the header size limit could cause Tomcat to treat a single request as multiple requests leading to the possibility of request smuggling when behind a reverse proxy. Older, EOL versions may also be affected. Users are recommended to upgrade to version 11.0.0-M11 onwards, 10.1.16 onwards, 9.0.83 onwards or 8.5.96 onwards, which fix the issue.
How to fix
- apache tomcat8.5.96, 9.0.83, 10.1.16 or later
- org.apache.tomcat:tomcat-catalina11.0.0-M11, 10.1.16, 9.0.83, 8.5.96 or later
- org.apache.tomcat.embed:tomcat-embed-core11.0.0-M11, 10.1.16, 9.0.83, 8.5.96 or later
- org.apache.tomcat:tomcat-coyote11.0.0-M11 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache tomcat | 8.5.0 ≤ v < 8.5.96, 9.0.0 ≤ v < 9.0.83, 10.1.0 ≤ v < 10.1.16, 11.0.0 | 8.5.96, 9.0.83, 10.1.16 |
| org.apache.tomcat:tomcat-catalinaMaven | 11.0.0-M1 ≤ v < 11.0.0-M11, 10.1.0-M1 ≤ v < 10.1.16, 9.0.0-M1 ≤ v < 9.0.83, 8.5.0 ≤ v < 8.5.96 | 11.0.0-M11, 10.1.16, 9.0.83, 8.5.96 |
| org.apache.tomcat.embed:tomcat-embed-coreMaven | 11.0.0-M1 ≤ v < 11.0.0-M11, 10.1.0-M1 ≤ v < 10.1.16, 9.0.0-M1 ≤ v < 9.0.83, 8.5.0 ≤ v < 8.5.96 | 11.0.0-M11, 10.1.16, 9.0.83, 8.5.96 |
| org.apache.tomcat:tomcat-coyoteMaven | 11.0.0-M1 ≤ v < 11.0.0-M11 | 11.0.0-M11 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.