CVE-2023-46604

CriticalActively exploited (CISA KEV)Known to be used in ransomware campaigns

Description

The Java OpenWire protocol marshaller is vulnerable to Remote Code Execution. This vulnerability may allow a remote attacker with network access to either a Java-based OpenWire broker or client to run arbitrary shell commands by manipulating serialized class types in the OpenWire protocol to cause either the client or the broker (respectively) to instantiate any class on the classpath. Users are recommended to upgrade both brokers and clients to version 5.15.16, 5.16.7, 5.17.6, or 5.18.3 which fixes this issue.

SeverityCritical
CVSS10.0
Exploit probability—
ProductApache ActiveMQ
PublishedOct 27, 2023
First seenOct 27, 2023
Added to KEVNov 2, 2023

How to fix

CISA required action

Apply mitigations per vendor instructions or discontinue use of the product if mitigations are unavailable.

CISA due date: Nov 23, 2023
Update
  • apache activemq5.15.16, 5.16.7, 5.17.6, 5.18.3 or later
  • apache activemq_legacy_openwire_module5.15.16, 5.16.7, 5.17.6, 5.18.3 or later
  • org.apache.activemq:activemq-client5.15.16, 5.16.7, 5.17.6, 5.18.3 or later
  • org.apache.activemq:activemq-openwire-legacy5.15.16, 5.16.7, 5.17.6, 5.18.3 or later

Affected products

ProductAffected versionsFixed in
apache activemqv < 5.15.16, 5.16.0 ≤ v < 5.16.7, 5.17.0 ≤ v < 5.17.6, 5.18.0 ≤ v < 5.18.35.15.16, 5.16.7, 5.17.6, 5.18.3
apache activemq_legacy_openwire_modulev < 5.15.16, 5.16.0 ≤ v < 5.16.7, 5.17.0 ≤ v < 5.17.6, 5.18.0 ≤ v < 5.18.35.15.16, 5.16.7, 5.17.6, 5.18.3
debian debian_linux10.0, 11.0—
netapp e-series_santricity_unified_managerNo range specified—
netapp e-series_santricity_web_services_proxyNo range specified—
netapp santricity_storage_pluginNo range specified—
org.apache.activemq:activemq-clientMavenv < 5.15.16, 5.16.0 ≤ v < 5.16.7, 5.17.0 ≤ v < 5.17.6, 5.18.0 ≤ v < 5.18.35.15.16, 5.16.7, 5.17.6, 5.18.3
org.apache.activemq:activemq-openwire-legacyMaven5.8.0 ≤ v < 5.15.16, 5.16.0 ≤ v < 5.16.7, 5.17.0 ≤ v < 5.17.6, 5.18.0 ≤ v < 5.18.35.15.16, 5.16.7, 5.17.6, 5.18.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.