CVE-2023-46647
Description
Improper privilege management in all versions of GitHub Enterprise Server allows users with authorized access to the management console with an editor role to escalate their privileges by making requests to the endpoint used for bootstrapping the instance. This vulnerability affected GitHub Enterprise Server version 3.8.0 and above and was fixed in version 3.8.12, 3.9.6, 3.10.3, and 3.11.0.
How to fix
- github enterprise_server3.8.12, 3.9.6, 3.10.3 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| github enterprise_server | 3.8.0 ≤ v < 3.8.12, 3.9.0 ≤ v < 3.9.6, 3.10.0 ≤ v < 3.10.3 | 3.8.12, 3.9.6, 3.10.3 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.