CVE-2023-46749
Medium
Description
Apache Shiro before 1.13.0 or 2.0.0-alpha-4, may be susceptible to a path traversal attack that results in an authentication bypass when used together with path rewriting Mitigation: Update to Apache Shiro 1.13.0+ or 2.0.0-alpha-4+, or ensure `blockSemicolon` is enabled (this is the default).
SeverityMedium
CVSS6.5
Exploit probability—
Product
Apache Shiro
PublishedJan 15, 2024
First seenJan 15, 2024
Weakness typeCWE-22Path traversal
How to fix
Update
- apache shiro1.13.0 or later
- org.apache.shiro:shiro-core1.13.0, 2.0.0-alpha4 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache shiro | v < 1.13.0, 2.0.0 | 1.13.0 |
| org.apache.shiro:shiro-coreMaven | v < 1.13.0, 2.0.0alpha1 ≤ v < 2.0.0-alpha4 | 1.13.0, 2.0.0-alpha4 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.