CVE-2023-47265

Medium

Description

Apache Airflow, versions 2.6.0 through 2.7.3 has a stored XSS vulnerability that allows a DAG author to add an unbounded and not-sanitized javascript in the parameter description field of the DAG. This Javascript can be executed on the client side of any of the user who looks at the tasks in the browser sandbox. While this issue does not allow to exit the browser sandbox or manipulation of the server-side data - more than the DAG author already has, it allows to modify what the user looking at the DAG details sees in the browser - which opens up all kinds of possibilities of misleading other users. Users of Apache Airflow are recommended to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability

SeverityMedium
CVSS5.4
Exploit probability—
ProductApache Airflow
PublishedDec 21, 2023
First seenDec 21, 2023

How to fix

Affected products

ProductAffected versionsFixed in
apache airflow2.6.0 ≤ v ≤ 2.7.3—
apache-airflowPyPI2.6.0 ≤ v < 2.8.0b12.8.0b1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.