CVE-2023-48218

Medium

Description

The Strapi Protected Populate Plugin protects `get` endpoints from revealing too much information. Prior to version 1.3.4, users were able to bypass the field level security. Users who tried to populate something that they didn't have access to could populate those fields anyway. This issue has been patched in version 1.3.4. There are no known workarounds.

SeverityMedium
CVSS5.3
Exploit probability—
ProductStrapi Protected Populate
PublishedNov 20, 2023
First seenNov 20, 2023

How to fix

Update
  • strapi protected_populate1.3.4 or later
  • strapi-plugin-protected-populate1.3.4 or later

Affected products

ProductAffected versionsFixed in
strapi protected_populatev < 1.3.41.3.4
strapi-plugin-protected-populatenpmv < 1.3.41.3.4

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-48218 · Strapi Protected Populate · Dark Radar