CVE-2023-48291

Medium

Description

Apache Airflow, in versions prior to 2.8.0, contains a security vulnerability that allows an authenticated user with limited access to some DAGs, to craft a request that could give the user write access to various DAG resources for DAGs that the user had no access to, thus, enabling the user to clear DAGs they shouldn't. This is a missing fix for CVE-2023-42792 in Apache Airflow 2.7.2  Users of Apache Airflow are strongly advised to upgrade to version 2.8.0 or newer to mitigate the risk associated with this vulnerability.

SeverityMedium
CVSS4.3
Exploit probability—
ProductApache Airflow
PublishedDec 21, 2023
First seenDec 21, 2023
Weakness typeCWE-668CWE-668

How to fix

Update
  • apache airflow2.8.0 or later
  • apache-airflow2.8.0 or later

Affected products

ProductAffected versionsFixed in
apache airflowv < 2.8.02.8.0
apache-airflowPyPIv < 2.8.02.8.0

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.

CVE-2023-48291 · Apache Airflow · Dark Radar