CVE-2023-48362

High

Description

XXE in the XML Format Plugin in Apache Drill version 1.19.0 and greater allows a user to read any file on a remote file system or execute commands via a malicious XML file. Users are recommended to upgrade to version 1.21.2, which fixes this issue.

SeverityHigh
CVSS8.8
Exploit probability—
ProductApache Drill
PublishedJul 24, 2024
First seenJul 24, 2024

How to fix

Update
  • apache drill1.21.2 or later
  • org.apache.drill.exec:drill-java-exec1.21.2 or later

Affected products

ProductAffected versionsFixed in
apache drill1.9.0 ≤ v < 1.21.21.21.2
org.apache.drill.exec:drill-java-execMaven1.19.0 ≤ v < 1.21.21.21.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.