CVE-2023-48705
Description
Nautobot is a Network Source of Truth and Network Automation Platform built as a web application All users of Nautobot versions earlier than 1.6.6 or 2.0.5 are potentially affected by a cross-site scripting vulnerability. Due to incorrect usage of Django's `mark_safe()` API when rendering certain types of user-authored content; including custom links, job buttons, and computed fields; it is possible that users with permission to create or edit these types of content could craft a malicious payload (such as JavaScript code) that would be executed when rendering pages containing this content. The maintainers have fixed the incorrect uses of `mark_safe()` (generally by replacing them with appropriate use of `format_html()` instead) to prevent such malicious data from being executed. Users on Nautobot 1.6.x LTM should upgrade to v1.6.6 and users on Nautobot 2.0.x should upgrade to v2.0.5. Appropriate object permissions can and should be applied to restrict which users are permitted to create or edit the aforementioned types of user-authored content. Other than that, there is no direct workaround available.
How to fix
- networktocode nautobot1.6.6, 2.0.5 or later
- nautobot1.6.6, 2.0.5 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| networktocode nautobot | v < 1.6.6, 2.0.0 ≤ v < 2.0.5 | 1.6.6, 2.0.5 |
| nautobotPyPI | v < 1.6.6, 2.0.0 ≤ v < 2.0.5 | 1.6.6, 2.0.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.