CVE-2023-48796

High

Description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache DolphinScheduler. The information exposed to unauthorized actors may include sensitive data such as database credentials. Users who can't upgrade to the fixed version can also set environment variable `MANAGEMENT_ENDPOINTS_WEB_EXPOSURE_INCLUDE=health,metrics,prometheus` to workaround this, or add the following section in the `application.yaml` file ``` management:   endpoints:     web:       exposure:         include: health,metrics,prometheus ``` This issue affects Apache DolphinScheduler: from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Dolphinscheduler
PublishedNov 24, 2023
First seenNov 24, 2023

How to fix

Update
  • apache dolphinscheduler3.0.2 or later
  • org.apache.dolphinscheduler:dolphinscheduler3.0.2 or later
  • apache-dolphinscheduler3.0.2 or later

Affected products

ProductAffected versionsFixed in
apache dolphinscheduler3.0.0 ≤ v < 3.0.23.0.2
org.apache.dolphinscheduler:dolphinschedulerMaven3.0.0 ≤ v < 3.0.23.0.2
apache-dolphinschedulerPyPI3.0.0 ≤ v < 3.0.23.0.2

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.