CVE-2023-49068

High

Description

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache DolphinScheduler.This issue affects Apache DolphinScheduler: before 3.2.1. Users are recommended to upgrade to version 3.2.1, which fixes the issue. At the time of disclosure of this advisory, this version has not yet been released. In the mean time, we recommend you make sure the logs are only available to trusted operators.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Dolphinscheduler
PublishedNov 27, 2023
First seenNov 27, 2023

How to fix

Update
  • apache dolphinscheduler3.2.1 or later
  • org.apache.dolphinscheduler:dolphinscheduler-api3.2.1 or later

Affected products

ProductAffected versionsFixed in
apache dolphinschedulerv < 3.2.13.2.1
org.apache.dolphinscheduler:dolphinscheduler-apiMavenv < 3.2.13.2.1

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.