CVE-2023-4919

Medium

Description

The iframe plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the `iframe` shortcode in versions up to, and including, 4.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permission and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This was partially patched in version 4.6 and fully patched in version 4.7.

SeverityMedium
CVSS6.4
Exploit probability—
ProductIframe
PublishedOct 20, 2023
First seenOct 20, 2023

How to fix

Update
  • iframe_project iframe4.7 or later

Affected products

ProductAffected versionsFixed in
iframe_project iframev < 4.74.7

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.