CVE-2023-49277

High

Description

dpaste is an open source pastebin application written in Python using the Django framework. A security vulnerability has been identified in the expires parameter of the dpaste API, allowing for a POST Reflected XSS attack. This vulnerability can be exploited by an attacker to execute arbitrary JavaScript code in the context of a user's browser, potentially leading to unauthorized access, data theft, or other malicious activities. Users are strongly advised to upgrade to dpaste release v3.8 or later versions, as dpaste versions older than v3.8 are susceptible to the identified security vulnerability. No known workarounds have been identified, and applying the patch is the most effective way to remediate the vulnerability.

SeverityHigh
CVSS8.3
Exploit probability—
ProductDarrennathanael Dpaste
PublishedDec 1, 2023
First seenDec 1, 2023

How to fix

Update
  • darrennathanael dpaste3.8 or later
  • dpaste3.8 or later

Affected products

ProductAffected versionsFixed in
darrennathanael dpastev < 3.83.8
dpastePyPIv < 3.83.8

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.