CVE-2023-49566
Description
In Apache Linkis <=1.5.0, due to the lack of effective filtering of parameters, an attacker configuring malicious db2 parameters in the DataSource Manager Module will result in jndi injection. Therefore, the parameters in the DB2 URL should be blacklisted. This attack requires the attacker to obtain an authorized account from Linkis before it can be carried out. Versions of Apache Linkis <=1.5.0 will be affected. We recommend users upgrade the version of Linkis to version 1.6.0.
How to fix
- apache linkis1.6.0 or later
- org.apache.linkis:linkis-datasource1.6.0 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache linkis | 1.4.0 ≤ v < 1.6.0 | 1.6.0 |
| org.apache.linkis:linkis-datasourceMaven | v < 1.6.0 | 1.6.0 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.