CVE-2023-49582
Medium
Description
Lax permissions set by the Apache Portable Runtime library on Unix platforms would allow local users read access to named shared memory segments, potentially revealing sensitive application data. This issue does not affect non-Unix platforms, or builds with APR_USE_SHMEM_SHMGET=1 (apr.h) Users are recommended to upgrade to APR version 1.7.5, which fixes this issue.
SeverityMedium
CVSS5.5
Exploit probability—
Product
Apache Portable Runtime
PublishedAug 26, 2024
First seenAug 26, 2024
Weakness typeCWE-732CWE-732
How to fix
Update
- apache portable_runtime1.7.5 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache portable_runtime | 0.9.0 ≤ v < 1.7.5 | 1.7.5 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.