CVE-2023-49734
Description
An authenticated Gamma user has the ability to create a dashboard and add charts to it, this user would automatically become one of the owners of the charts allowing him to incorrectly have write permissions to these charts.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2 or 2.1.3, which fixes the issue.
How to fix
- apache superset2.1.2, 3.0.2 or later
- apache-superset2.1.3, 3.0.2 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache superset | v < 2.1.2, 3.0.0 ≤ v < 3.0.2 | 2.1.2, 3.0.2 |
| apache-supersetPyPI | v < 2.1.3, 3.0.0 ≤ v < 3.0.2 | 2.1.3, 3.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.