CVE-2023-49736
Medium
Description
A where_in JINJA macro allows users to specify a quote, which combined with a carefully crafted statement would allow for SQL injection in Apache Superset.This issue affects Apache Superset: before 2.1.2, from 3.0.0 before 3.0.2. Users are recommended to upgrade to version 3.0.2, which fixes the issue.
SeverityMedium
CVSS6.5
Exploit probability—
Product
Apache Superset
PublishedDec 19, 2023
First seenDec 19, 2023
Weakness typeCWE-89SQL injection
How to fix
Update
- apache superset2.1.2, 3.0.2 or later
- apache-superset2.1.3, 3.0.2 or later
Vendor advisories
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache superset | v < 2.1.2, 3.0.0 ≤ v < 3.0.2 | 2.1.2, 3.0.2 |
| apache-supersetPyPI | v < 2.1.3, 3.0.0 ≤ v < 3.0.2 | 2.1.3, 3.0.2 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
In the Intelligence 360 plan
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.