CVE-2023-49920
Description
Apache Airflow, version 2.7.0 through 2.7.3, has a vulnerability that allows an attacker to trigger a DAG in a GET request without CSRF validation. As a result, it was possible for a malicious website opened in the same browser - by the user who also had Airflow UI opened - to trigger the execution of DAGs without the user's consent. Users are advised to upgrade to version 2.8.0 or later which is not affected
How to fix
- apache-airflow2.8.0, 2.8.0b1 or later
Affected products
| Product | Affected versions | Fixed in |
|---|---|---|
| apache airflow | 2.7.0 ≤ v ≤ 2.7.3 | — |
| apache-airflowPyPI | 2.7.0 ≤ v < 2.8.0, 2.7.0 ≤ v < 2.8.0b1 | 2.8.0, 2.8.0b1 |
Check your version
Choose the product and enter the version you run to see whether it falls in the affected range.
Attack Surface Management
See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.