CVE-2023-50292

High

Description

Incorrect Permission Assignment for Critical Resource, Improper Control of Dynamically-Managed Code Resources vulnerability in Apache Solr. This issue affects Apache Solr: from 8.10.0 through 8.11.2, from 9.0.0 before 9.3.0. The Schema Designer was introduced to allow users to more easily configure and test new Schemas and configSets. However, when the feature was created, the "trust" (authentication) of these configSets was not considered. External library loading is only available to configSets that are "trusted" (created by authenticated users), thus non-authenticated users are unable to perform Remote Code Execution. Since the Schema Designer loaded configSets without taking their "trust" into account, configSets that were created by unauthenticated users were allowed to load external libraries when used in the Schema Designer. Users are recommended to upgrade to version 9.3.0, which fixes the issue.

SeverityHigh
CVSS7.5
Exploit probability—
ProductApache Solr
PublishedFeb 9, 2024
First seenFeb 9, 2024
Weakness typeCWE-732CWE-732

How to fix

Update
  • apache solr8.11.3, 9.4.1 or later
  • org.apache.solr:solr-core9.3.0, 8.11.3 or later

Affected products

ProductAffected versionsFixed in
apache solr6.0.0 ≤ v < 8.11.3, 9.0.0 ≤ v < 9.4.18.11.3, 9.4.1
org.apache.solr:solr-coreMaven9.0.0 ≤ v < 9.3.0, 8.10.0 ≤ v < 8.11.39.3.0, 8.11.3

Check your version

Choose the product and enter the version you run to see whether it falls in the affected range.

In the Intelligence 360 plan

Attack Surface Management

See the assets tied to your domains, the technologies they run and known vulnerabilities in one list.